What happened to the search function?

mmcguckin1

ΜΟΛΩΝ ΛΑΒΕ
Supporter
Full Member
Minuteman
  • Apr 16, 2020
    157
    40
    Michigan
    For the last few days the search function only returns errors?? Anyone else experiencing this?
     

    skyewalker

    Gunny Sergeant
    Full Member
    Minuteman
    Jan 7, 2014
    559
    99
    New Mexico
    It's still there in the top right corner, however it will not search each individual category like it used tom (optics, firearms etc), instead it will only search the entire PX forum.

    1615216134460.png
     

    mmcguckin1

    ΜΟΛΩΝ ΛΑΒΕ
    Supporter
    Full Member
    Minuteman
  • Apr 16, 2020
    157
    40
    Michigan
    So I get this now when I search, then when I click on the links (the the one circled) it gives me an error...not found.

    Screenshot 2021-03-08 102058.png
     

    DIBBS

    Old Mountain Man-Tired occasionally Grumpy SOB
    Full Member
    Minuteman
  • Aug 21, 2008
    1,989
    1,193
    WARSHington State
    I get the same error message as @mmcguckin1 when searching .

    While the topic will come up from your search parameters, the links to the thread do not work.

    I am Using DuckDuckgo search engine.

    I can't remember the computer whiz that does the work here or I would PM him directly with the link to this discussion/question

    I posted a link to this discussion in the Lowlight Directives subforum... if anyone can remember the IT persons name that helps with the site possibly forward a link to this thread to him? Thanks.
     
    Last edited:
    • Like
    Reactions: mmcguckin1

    mmcguckin1

    ΜΟΛΩΝ ΛΑΒΕ
    Supporter
    Full Member
    Minuteman
  • Apr 16, 2020
    157
    40
    Michigan
    I get the same error message as @mmcguckin1 when searching .

    While the topic will come up from your search parameters, the links to the thread do not work.

    I am Using DuckDuckgo search engine.

    I can't remember the computer whiz that does the work here or I would PM him directly with the link to this discussion/question
    I just recently switched to Duck Duck go and that seems to be the problem. Changed my default search engine back to Google and it works fine.
    Darn...
     
    Last edited:

    alexj-12

    Administrator
    Staff member
    Moderator
    Full Member
    Minuteman
  • Jul 17, 2020
    120
    165
    Illinois
    I just recently switched to Duck Duck go and that seems to be the problem. Changed my default search engine back to Google and it works fine.
    Darn...
    Hey there! I just tested out the search bar using Duck Duck Go and was able to replicate the issue. Unfortunately, this isn't an issue we can fix as it's a problem with the forum software we use. So I've reported it to the developers of the software and we'll hopefully get a fix soon
     

    MarinePMI

    Ban Cat Handler
    Staff member
    Moderator
    Commercial Supporter
    Full Member
    Minuteman
  • Jun 3, 2010
    7,340
    9,456
    San Diego, Ca
    Hey there! I just tested out the search bar using Duck Duck Go and was able to replicate the issue. Unfortunately, this isn't an issue we can fix as it's a problem with the forum software we use. So I've reported it to the developers of the software and we'll hopefully get a fix soon
    Thanks Alex! We appreciate all the hard work you and your team put in to keeping this place moving forward.

    BZ
     

    alexj-12

    Administrator
    Staff member
    Moderator
    Full Member
    Minuteman
  • Jul 17, 2020
    120
    165
    Illinois
    I'm sorry we haven't had any luck. Since this isn't something we can directly control, I reported the issue to the forum software we use and to the extension for search that we use and I do not believe a fix for the problem has been put out yet. Sorry about that!
     

    alexj-12

    Administrator
    Staff member
    Moderator
    Full Member
    Minuteman
  • Jul 17, 2020
    120
    165
    Illinois
    Yes. when I reached out about this issue I was told that it was an issue with Threadloom search, but I have not seen a fix for it so far.
     
    • Like
    Reactions: DIBBS

    CcoFirst

    SLB
    Full Member
    Minuteman
    Apr 27, 2019
    132
    122
    54
    Biloxi
    I use Duck Duck go and get the same error, use Chrome Google and it goes away as stated already
     

    barnaby

    Private
    Full Member
    Minuteman
    Jun 21, 2014
    59
    7
    Raleigh NC
    In my case (Brave Browser on Mac) it is the DuckDuckGo privacy extension that causes the search error.

     2021-04-29 at 17.19.06 .png


    The above extension enabled == problem.

    But you can change the search engine to DuckDuckGo manually..

     2021-04-29 at 17.19.17 .png


    Search works. So disable or remove the extension and change default search the old fashioned way.
     
    Last edited:

    Dobermann

    Sergeant of the Hide
    Full Member
    Minuteman
    May 28, 2020
    158
    75
    Hmmm ... I've been having the same problem for a couple of months. If there's any way it can fixed for others who use Firefox + DuckDuckGo, that would be great ... plenty of people do, for privacy reasons.
     

    lash

    Swamp Rat
    Full Member
    Minuteman
    Sep 28, 2012
    7,575
    9,845
    62
    Central Florida
    Hmmm ... I've been having the same problem for a couple of months. If there's any way it can fixed for others who use Firefox + DuckDuckGo, that would be great ... plenty of people do, for privacy reasons.
    The post directly above yours shows you a way to do it.

    here it is:
    In my case (Brave Browser on Mac) it is the DuckDuckGo privacy extension that causes the search error.

    View attachment 7614836

    The above extension enabled == problem.

    But you can change the search engine to DuckDuckGo manually..

    View attachment 7614837

    Search works. So disable or remove the extension and change default search the old fashioned way.
     

    mbeavers1

    Supporter
    Supporter
    Full Member
    Minuteman
    Nov 27, 2019
    366
    116
    Montgomery, TX
    Im having the issue on Google Chrome on my Android phone. When I click on the search icon, nothing happens. I have restarted multiple times but no luck.
     

    alexj-12

    Administrator
    Staff member
    Moderator
    Full Member
    Minuteman
  • Jul 17, 2020
    120
    165
    Illinois
    Im having the issue on Google Chrome on my Android phone. When I click on the search icon, nothing happens. I have restarted multiple times but no luck.
    I'll see if we can identify the issue happening here and get a fix out
     

    Mike_in_FL

    Supporter
    Supporter
    Full Member
    Minuteman
  • Feb 29, 2008
    1,103
    236
    Tampa Bay, FL
    I had the same problem on Chrome with DDG search. Here's a workaround. Click the extensions symbol in the browser while you're on the SH page and go down to the DDG extension. Then disable privacy protection on just this site. Search should work for you now.
     

    alexj-12

    Administrator
    Staff member
    Moderator
    Full Member
    Minuteman
  • Jul 17, 2020
    120
    165
    Illinois
    Im having the issue on Google Chrome on my Android phone. When I click on the search icon, nothing happens. I have restarted multiple times but no luck.
    Hey just wanted to let you know that we put out a fix for this! Let me know if you're having any other problems
     

    CaptArab

    Sergeant of the Hide
    Full Member
    Minuteman
    Aug 3, 2020
    146
    62
    Lots of times the site doesn't appear to work because Im coming from search which returns a cached HTTP link. Of course HTTP won't work for lots of things.

    The site should redirect from HTTPS to HTTPS on all requests.

    That and the z index of the notifications is messed up on mobile on the homepage so that you have to click forum to see your notifications after seeing the alert.

    Those are really the only two bugs on this site. Which is pretty amazing compared to all the other gun forms out there.